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 Since 1990s, CNDC has been devoting to develop 

plotting software for nuclear data. The first window’s 

plotting software named  TT was released in 2002. 

 TT is a Chinese abbreviation and short for “Tong 

Tiao（统调）”, it means comparison and adjustment. 

 TT ‘s software structure  is Client-Server.

 The sever has a database including ENDF and 

EXFOR.
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 History
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 TT example: 

56Fe(n, 2n) 

reaction
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Interface of TT
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 History



GUI

（Graphical User Interface）

Programming Language
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TT’s Development Platform

PERL

TK（GUI）

Single 

Dialogue
Window

Single 

Canvas
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NDPlot is a more efficient nuclear data 

plotting tool,  It’s not only a plotting tool,  but 

also a Integrated application software.

It can be seen as an updated version of TT.

Convenience Traceability Reusability

Purpose

Introduction of NDPlot
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Introduction of NDPlot

Convenience：Online, and All the experimental data 

and evaluated data are converted to uniform units

Traceability: lots of information can be stored in a 

project file, users can view it at anytime they 

want.  Information include: original data, plotting 

data， coordinate system, annotations, remarks.

Reusability: You can save or continue the work at any 

time. Others can use the file to continue , examine or 

edit the file.



Features of NDPlot

 Treatment of CS, DA, DE, DAE,MFQ,FY etc.;

 Using EXFOR, ENDF, and user-defined format data 

(free format);

 Saving  project  File;

 Exporting figures as jpg, eps, pdf, etc. ;

 Supporting Windows clipboard (word, ppt);

 Online retrieve & transfer the exp. and eval. data 

from the database.
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 Architecture of NDPlot

10

Client-Server Structure

Application Server Database

NDPlot Client
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Client GUI

Client Programming Language
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PERL

WxWindows

（GUI）

MDI(Multi-

Document 

Interface)

More Canvas

Development Platform of NDPlot
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 Input & Output

Introduction of NDPlot
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 Codes written by others are called by NDPlot:

1 Endver : LSTTAB,X4TOC4. Prepro: Convert ENDF to PENDF

Introduction of NDPlot
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Interface

1                        2                         3…
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: Screenshot

MainFrame:

Menu bar

ChildFrame:

Control Panel

Canvas
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 Batch Plotting(DA,DE,DAE)

The data can be 

plotted in one or 

more windows.

It can plot more 

than one 

reaction at the 

same time.

Introduction of NDPlot
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Register And Login

Introduction of NDPlot



Why need to register?
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Server

Solving resource conflict on server side

User.1 …

Temp file.1 Temp file.n…

User.n

Temp file.1 Temp file.n…

Work 

Directory
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[File Menu]

Introduction of NDPlot



20

File->New: Create a new window（ChildFrame）
File->Save （AS）：Save current  window（.ND）(Ctrl+S)

File->Open：Open a ND file(.ND) (Ctrl+O)

File->Save Project : All windows will be stored（.NDS）
File->Open Project:  Open a project File（.NDS）
File->Close :  Close Current ChildFrame.

File->Print Preview

File->Print (Ctrl+P)

File->Save Picture：Output  current  window as a 

picture(JPG,BMP,GIF,PNG);

File->Login: Online

File->Exit

Introduction of NDPlot
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[Data Menu]

Introduction of NDPlot
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Data->Import Text Data：free format data

Data->Connect to  Evaluated Lib:  Retrieve data from Eva. Lib（Alt+E）
Data->Evaluated Lib Tree: Show the Eva. Lib information  in tree form.

Data->Ratio of Eva. Data: Ratio of Cross Section(same lib)

Data->Ratio of Eva. Data with diff. lib:

Ratio of Cross Section(same lib)

Data->Connect to EXFOR Lib (Alt+X)

Data-> Open Exp. Data (NDPlot format)

Data-> Open Eva. Data (NDPlot format)

Data->Manipulating Data  （Alt+D）: Chang the size, color, 

annotation …of point or curve ; View data ,original data..;

Column Operation for data;

Data->Chain Yield:  Chain Yield of Fission Product 

Data->Yield  Energy Independence:  Yield  Energy Independence of 

Fission Product 

Introduction of NDPlot



[Data Menu->Import Text Data]
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[Data Menu-> Connect to  Evaluated Lib]
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[Data Menu-> Connect to  Evaluated Lib]

Adding Exp. Data
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[Data Menu-> Evaluated Lib Tree]
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[Data Menu-> Ratio of Eva. Data
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[Data Menu-> Ratio of Eva. Data]
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[Data Menu-> Ratio of Eva. Data]

Adding Exp. Data
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[Data Menu-> Ratio of Eva. Data]

ENDFB7.1  N,FISSION CS/ N,TOT CS
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[Data Menu-> Ratio of Eva. Data With Different Lib]
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[Data Menu->Open EXP(EVA) File(Ndplot format)]

The Data is outputted by Manipulating data Window



NDPlot Text Data Format
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[Data Menu->Manipulating Data]
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[Data Menu->Manipulating Data]

1 2
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[Data Grid : Support Column Operation]

3



Column Operation :Degree -》Radian -》Cosine
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cos(deg2rad([a]))
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The operators and functions in Column Operation



 [Data->Chain Yield(Evaluated)]:  Chain Yield of Fission 

Product 

 [Data->Yield  Energy Independence(Evaluated)]:  Yield  

Energy Independence of Fission Product
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[Annotations Menu]

Introduction of NDPlot
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[Edit]

Introduction of NDPlot
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[Edit->Delete Text]

Any text box can be added to the canvas
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[Edit->Clipboard]

Graph

Exp. Data

Eva. Data
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[Font]

Introduction of NDPlot
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[Axis]

Introduction of NDPlot
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[Utilities]
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[Utilities->Prepro]

MF=3,4,5,6
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[Utilities->(P)Endf File Tree]

MF=3,4,5,6
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[Tools]

Introduction of NDPlot
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[Tools-Element,MF,MT]
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[Tools->EX4 SubEntry]
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[Tools->EX4 Tool]

10999002
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[Tools->EX4 Tool]
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[Tools->EX4 Tool->Output CSV File]
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[Global Environment Settings]

Introduction of NDPlot
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[Remarks]

Introduction of NDPlot
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BatchPlotting（for DA，DE，DAE）

Introduction of NDPlot
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Each energy has a window



[Canvas]
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[QuickChoice]
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Click/(Double Click) On Canvas
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Click/Exp. Data Point

Click the Exp. Point(Left 

Button of Mouse)

Popup Menu(Right 

Button of Mouse Clicks )
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Display local area 
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Visualization of Fission Product Yield
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Chain Yield
Yield Energy 

Independence

There are two kinds of visualization that need to be solved urgently

process the data manually

Very inefficient
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Evaluated Data:

MF=8,MT=454,459

Exp. Data

FY(CUM,IND,CHN)

Visualization of Fission Product Yield
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Experimental Data of Fission Product need more complex structures  

Visualization of Fission Product Yield
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Visualization of Fission Product Yield



78

Server

NDPlot

NDPlot

Format

Energy 

Data 

Structure

Products

Data

Structure

Multilevel 

Nested data 

Structures 2

Multilevel Nested 

Data Structures 1

Visualization of Fission Product Yield
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Demonstrations：Chain Yield
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Demonstrations：Chain Yield
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Demonstrations：Chain Yield
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Demonstrations：Chain Yield
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Demonstrations：Chain Yield

Discrepancy between

Exp.  and Eval.
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Demonstrations：Chain Yield

Display Local area
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Demonstrations：Chain Yield

Arb-Units Data is not completely unusable

shift the points downwards by column operation
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Demonstrations：Chain Yield

shift the points downwards by column operation

92-U-235(N,F)ELEM/MASS,CUM,FY
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Demonstrations：Chain Yield

shift the points downwards by column operation
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Demonstrations：Chain Yield

shift the points downwards by column operation
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Demonstrations：Chain Yield

shift the points downwards by column operation

92-U-235(N,F)ELEM/MASS,CUM,FY
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Demonstrations：Chain Yield

shift the points downwards by column operation
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Demonstrations：Chain Yield

shift the points downwards by column operation

According to ENDFB8：
100%，99%，97%，95%

In ENDF/B8-FY,

If the cumulative yield of the product (z,a,m) >= 

100%(99%,97%,95%)*chain-yield,

the product can be chosen.  
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Demonstrations：Chain Yield—Gamma Correction
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Demonstrations：Chain Yield—Gamma Correction

The data in red cell  is corrected 

FYcorrected=1/( Max(Intensityexfor)/ Intensitynew)*FY



96

Demonstrations：Yield Energy Independence
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Demonstrations：Yield Energy Independence
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Demonstrations：Yield Energy Independence
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Demonstrations：Yield Energy Independence

Evaluated  Data
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Demonstrations：Yield Energy Independence
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Summary

NDPlot is an efficient plotting software for nuclear 

data and easy to use.

It can be All-in-one (information)

 The Work base on EXFOR database and some 

tools provided from NDS. Thanks to NDS and IAEA, 

especially Thanks to  Viktor ZERKIN. 
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Prospect

New function such as  correction exp. Data with 

standard cross sections 

Low network speed should be considered. 

More friendly human-machine interface



Website: http://www.nuclear.csdb.cn/ndplot/



China Nuclear Data Center 

China Institute of Atomic Energy

P.O.Box 275-41, Beijing 102413, P.R.China

Thank you for your attention !
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