
JSON-Tree Editor
by Viktor Zerkin

~ independent software developer ~

EXFOR Workshop: Compilation of Experimental Nuclear Reaction Data

3 - 6 December 2024, IAEA Headquarters, Vienna, Austria



Part I.

Introduction. Purpose. Concept.



JSON (JavaScript Object Notation) is a lightweight data-interchange format
JSON is based on a subset of the JavaScript since 1999. JSON is a text format that is language independent 

but uses conventions familiar to programmers of the C-family of languages (C/C++, C#, Java, JavaScript), 

Perl, Python, and many others.

JSON is built on two structures:
• A collection of name/value pairs. In various languages, this is realized as an object, record, struct, 

dictionary, hash table, keyed list, or associative array.

• An ordered list of values. In most languages, this is realized as an array, vector, list, or sequence.

Advantages
• vs. plain text: easy to describe complex data and nested structures; many programming languages 

provide Parser (easier for programming of read/write operations)

• vs. XML: simpler, much shorter (~ ×5 times)

• vs. DB: do not need special tools to view data (files are just text)

• super-easy to manipulate in programs in JavaScript (Web) and Python (desktop)

Disadvantages
• vs. plain text: extra-text (key, : and ““). 

Example of parameter and named parameter in plain text and JSON:

text file: A1234 #program uses assigned variable name, known location in the file and format

text file: ENTRY A1234 #program uses known location in the file and format; name changed dynamically

json file: ”ENTRY”:”A1234” #program needs separators: +5 characters (with flexible location)

• vs. XML: less flexible (XML: <tag attributes>body</tag>, JSON: {key:value} no attributes)

• vs. DB: need extra tools for data search and manipulations

• vs. JavaScript/object and Python/dict: no comments allowed, double-quats 

alternative: “JSON5 – JSON for Humans” - see https://json5.org/

Introduction. JSON.



JSON for Nuclear Data
Web retrieval systems (examples on my own experience)

• JavaScript programming of dynamic pages: update page asynchronously without full reloading using 

JSON in communication with Web-Server via AJAX (Asynchronous JavaScript and XML). 

Example: EE-View.

• View page with retrieved data via JSON: simpler Web-programming, re-use JSON files for Web-API 

for external users with remote programs.

2000. Web-pages: DB => Java => html+JavaScript => JS-code => Internet => html in Web-browser

2020. Web-pages: DB => Java => html+JSON => JS-code => Internet => html in Web-browser

+ Web-API:    DB => Java => JSON => Internet => User’s program/Python/Java/wget/curl/etc.

Examples: ENDF Decay-Data view and comparison; Web-API for EXFOR, ENDF, IBANDL

Data and formats modernization, new technologies, new tasks, new developers, new users
(related not only to new IT technologies and the younger generation, but also to a more dynamic rotation policy)

• Modernize and develop new formats in data centers and user communities to improve/simplify data access, 

increase data usage, making data accessible to more users, reducing the barrier to entrance.

Examples: NRDC (X5), NDS (J4, Dictionary), NNDC (ENSDF), WPEC-SG50 (MEDUSAL)

• NRDC-2024: A71  All  (Continuing action) Analyze X5 structure/hierarchy and contents, 

contact Zerkin with questions and proposals. 

• Off-line distribution to “large users” using entire content of nuclear data libraries to build ML and other 

systems based on new technologies.

Structure, options and agreement on JSON formats for nuclear data
(Note. JSON is a notation that can be used to define a format, but not the format itself)

• Although it is easy to produce data in JSON as output from modern programs, the format (schema/structure 

and data types) delivered to end-users should be correct (cross-checked) and stable (agreed between data 

centers and fixed for observable time). We need to understand proposed JSON formats and discuss options.

• To achieve this, we need a JSON-Viewer, and possibly, an Editor, and preferably Web based.

JSON for nuclear data.



Before development. Development loop

Steps to go.

1. Understand problem and possibly task(s)

2. Three questions to answer:

a) What already exists and can be used?

b) What is wrong now?

c) What do we want to achieve? (define ideal goal)

3. Preparations:

a) discuss/define main ideas, concept and possible technologies

b) study and test technologies, select technology

4. Plan: split problem to tasks/sub-tasks, define dates

5. Implementation: development loop

a) Define/invent data structures and algorithms

b) Developing program/modules + testing + feedback and correction tasks

c) Go to -2 = 5.a) or to 4. or even to 3. when needed



Some Web links used before development
JSON tree, XML, beautifiers: 

https://countwordsfree.com/jsonviewer

https://codebeautify.org/jsonviewer

example with URL: 
https://codebeautify.org/jsonviewer?https://codebeautify.org/jsonviewer?url=https://nds.iaea.org/

exfor/x4guide/x5json/23114002.x4z.txt

JSON validators:   https://jsonlint.com/    https://codebeautify.org/jsonvalidator

JSON-schema: https://www.nndc.bnl.gov/ensdfschema/

Properties (why insufficient for our purposes)
• general purpose products (no specialized features)

• work only via Web (no local version)

• fixed functionality (no user’s extensions and new functions)

Our needs and existing JSON web-tools

Our purposes
• understand proposed JSON based nuclear data formats on examples (!!!)

• test JSON files (investigate structure, evaluate rationality), find mistakes, report bugs

• discuss and modify JSON files to make counterproposals and improve formats

• accept proposed JSON formats and make sure that it is common agreed format



https://vzerkin.github.io/
https://zerkin.usite.pro/edit-json-tree/

JSON-Tree Editor: a tool to understand 

and discuss nuclear data formats

Links with preload examples:

https://zerkin.usite.pro/edit-json-tree/ example: start with types of JSON objects

https://zerkin.usite.pro/edit-json-tree/#0 new: start with empty JSON

https://zerkin.usite.pro/edit-json-tree/#1 X5json for EXFOR #13597

https://zerkin.usite.pro/edit-json-tree/#4 Dictionary by N.Otsuka (9130)

https://zerkin.usite.pro/edit-json-tree/#4o Dictionary by S.Okumura

https://zerkin.usite.pro/edit-json-tree/#4z Dictionary for Apps by V.Zerkin

https://zerkin.usite.pro/edit-json-tree/#5 ensdf-json by NNDC

https://zerkin.usite.pro/edit-json-tree/#7 nsr_result by NNDC

https://zerkin.usite.pro/edit-json-tree/#9 exfor_json by S.Okumura

https://zerkin.usite.pro/edit-json-tree/#10 EXFOR-Std in JSON by V.Zerkin (2019)

https://zerkin.usite.pro/edit-json-tree/cmp2h.htm parallel: compare 2 JSON files (horizontal)

https://zerkin.usite.pro/edit-json-tree/cmp2v.htm parallel: compare 2 JSON files (vertical)

https://zerkin.usite.pro/edit-json-tree/cmp3vh.htm parallel: compare 2 JSON files (vert.+hor.)

https://zerkin.usite.pro/edit-json-tree/cmp3dict.htm compare 3 Dictionaries: SO | NO | ZV

For the moment, we can discuss JSON of EXFOR (~5 versions), Dictionaries (3 versions), 

ENDF-MF3/33, 4/34, Decay-data; IBANDL; ENSDF; NSR-output



Concept and technology

JSON-Tree Editor

1. presents JSON as interactive-tree

2. is an Application running in Web-browser

a) written in JavaScript

b) work from Web-server and locally (no server needed)

c) platform independent (running “inside” Web browser on any OS)

d) input: copy/paste or select local JSON file

e) output: save JSON to browser’s download area

3. looks and operates like “native” App - intuitive for users

4. implements traditional editor’s functionality

5. provides extra-fuctionality for known nuclear data formats

6. is easy for extensions

My past experience with Web-iTree and Web-editors:

x4±, ensdf±, web-editors: exfor (draft), ensdf



Front-page on GitHub. Overview.

JSON-Tree Editor: https://vzerkin.github.io/

JSON-Tree Editor
by V.Zerkin, 2024

Purpose/Features/Links:

• Currently, the main goal: development of JSON formats for nuclear data
• Presenting any JSON text as interactive tree in order to learn/understand/compare/discuss data formats: 

structures/contents/hierarchy
• Test samples: JSON files generated by nuclear data systems EXFOR, ENDF, Web-API, NSR, ENSDF, etc.

• Viewer-part is extendable to display specific information along with the node name

• Editor implements operations:
• File: new/save/open local JSON file

• Edit: undo/redo
• View: open 1 level of nesting, 2 levels, 3 levels, . . ., 8 levels, open all nodes

• History: view history of operations, select and roll back to previous editing steps

• Tool: minify/expand/iTable current JSON text in popup-window

• Node in the graph-tree: JSON <key-value>

• Edit: modify/clear/check/minify/expand/copy/paste JSON-text of “value” and modify “key”

• Add: edit Node and save it as new Node, add item to Array

• Move: move whole Node up and down

• Remove: delete whole Node
• Edit-json-tree online:

• vzerkin.github.io: edit-json-tree, x5, x4std, ensdf, pace_ensdf; parallel view/edit: exfor, dict, nsr
• zerkin.usite.pro: edit-json-tree, x5, x4std, ensdf, pace_ensdf; parallel view/edit: exfor, dict, nsr

• Editor can also be used in local Web-Browser without Web-server.

https://nds.iaea.org/exfor/
https://nds.iaea.org/endf/
https://nds.iaea.org/exfor/x4guide/API/
https://www.nndc.bnl.gov/nsr-dev/
https://vzerkin.github.io/edit-json-tree/
https://vzerkin.github.io/edit-json-tree/#1
https://vzerkin.github.io/edit-json-tree/#10
https://vzerkin.github.io/edit-json-tree/#5
https://vzerkin.github.io/edit-json-tree/#11
https://vzerkin.github.io/edit-json-tree/cmp2exfor.htm
https://vzerkin.github.io/edit-json-tree/cmp2dict.htm
https://vzerkin.github.io/edit-json-tree/cmp2nsr.htm
https://zerkin.usite.pro/edit-json-tree/
https://zerkin.usite.pro/edit-json-tree/#1
https://zerkin.usite.pro/edit-json-tree/#10
https://zerkin.usite.pro/edit-json-tree/#5
https://zerkin.usite.pro/edit-json-tree/#11
https://zerkin.usite.pro/edit-json-tree/cmp2exfor.htm
https://zerkin.usite.pro/edit-json-tree/cmp2dict.htm
https://zerkin.usite.pro/edit-json-tree/cmp2nsr.htm


JSON-Tree Editor: X5
File: drop-down 

menu
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Part II.

Start. Input. Viewer.



Start. Open in Web-Browser URL address:   https://zerkin.usite.pro/edit-json-tree/

Start. Input JSON.

Input.

1) File → Open → Select file on you PC

2) File → New #start with empty JSON object: {}

3) File → Test samples → Select example of JSON

4) Copy/Paste:
1) Mouse-over any Node-Key displays tool-tip prompt: [Edit]

2) Click on Node-Key 

3) It will open editing-area

4) Use operations: [Clear] and keyboard: <Ctrl/V> to paste text. 

Note. <Ctrl/A>,<Ctrl/C>,<Ctrl/V>,<Ctrl/Z> work on text as usual

5) Use operation [Save] to store JSON as Node in the tree



By default JSON data are presented by pairs <key:value> or <key:object> in the tree graph 

with colors and display object type and length.

JSON-Viewer

{10} – means: object 

with 10 members

[20] – means: array (list)  

with 20 elements

basic types: just 

colored key (brown), 

value (cyan)

[3] – means: top level 

array (list) has 3 rows 

(entire matrix: 3×5)

Arrays with complex 

elements are shown with 

key: array-kye[index]

Simple values without further structuring

Array [length]

Object [length]

Collapse

(open)

Click on Key → open edit panel

(second click → close edit panel)

Open

(collapse)



JSON-Viewer. Extended functionality.

Pull up the lower level (no need to collapse very node below)

Collapsed

Open navigation panel

Note. Cyan background outlines content of affected node



For known JSON formats, data can be displayed with additional useful information. 

The idea is to configure viewer as necessary.

JSON-Viewer

Additional info when useful 

and if configured

ENSDF: level energy, half-

life, number of gammas

EXFOR: FreeText is shown with 

css:“no-wrap;mono-space” to display 

tabulated text and see every “space”

Dictionary: code 

expansion from the 

underlying object

R33: main meta-data and 

parameters of  Datasets



Looking on a new large JSON file, sometimes it is needed to quickly understand it’s structure 

by opening nested levels of information. In order to do this Editor provides operations 
View → open 1 level

View → open 2 levels

. . .

View → open all

Fast overview the JSON structure



Display JSON file as interactive table with possibility to show/hide data and option to show 

original text or sub-table structured by JSON key:value. Initially data displayed it table with 

two columns with Key and Value; if Value is complex (list or object) it will be presented as a 

sub-table with multiple rows.

Additional viewer: iTable



Part III.

Editing. Save result.



Editing starts by Mouse-click on a key.

Basic principle. Content of every Node is JSON {key:value} – both are text and both can be edited. This means:

1) Key can be changed but must be unique on it’s level (can not be the same as other keys)

2) Value: simple values (like number) and huge JSON-text can be edited in dedicated text area

Edit key and value

[Save] will modify Node

[Save New] will add new Node

after one which was edited.

Edited node is shown with light-

cyan background (node before 

editing)

Move node up/down –

Close node without saving -

Editing



Every modification of node content or position in the current tree is recorded and can be 

restored by user if necessary to one or more steps. Actions can also be repeated.

1. Undo/Redo are used to cancel or repeat last operations.

Edit → Undo

Edit → Redo

2. History shows operations which were recently done and allows to return to any step back

History → Versions      #show what was done + return back

History → Operations  #show what was done

Mouse-click on Version[number]      will return JSON

to the needed version

Undo/Redo. History. Restore JSON versions.



Output.

1) File → Save

2) Now your current JSON file is stored in the Download area of your Web-Browser

Save result

1

2



Back to purpose. Viewer. Practical example.
Compare 3 Dictionary versions: https://zerkin.usite.pro/edit-json-tree/cmp3dict.htm

(Note. Although all three are built for different purposes and uses, we can explore technical details, see drawbacks and find bugs.)

S.Okumura(~2022)  N.Otsuka(2024) V.Zerkin(2024)



Understanding/comparing 3 Dictionaries.
S.Okumura(2022-2024)

No description, no timestamp

#dictionaries 32

File structure dict*

Dictionary-struct. dict

Dict-236 #codes 885

N.Otsuka(2024)

EXFOR/CINDA Dictionary in JSON

#dictionaries 42

File structure dict

Dictionary-struct. list

Dict-236 #codes 892

V.Zerkin(2024)

EXFOR Dictionaries for Applications

#dictionaries 51

File structure list*

Dictionary-struct. list

Dict-236 #codes 8911 2 3

1

2

3

Looking to all 3, questions and comments:

C1: (1) incompleteness (e.g. Dict-236: no “reaction type code” given)

Q1: (1) Why ZPP appears in 235 and 236? (bug?)

Q2: (1) Why Dict-236 is shorter? (bug? GitHub: “Updated on Jul 31”)

Q3: (1) D236 has 6 codes starting with “(“, but (2) and (3) – 17 (bug?)

Q4: (2) code=”” can only be [0] element of the list of codes?

etc.

*dict - hash table, keyed list, associative array

*list  - ordered list of values, array, vector



Example: proposal to change X5 structure
Edit X5json: https://zerkin.usite.pro/edit-json-tree/#1

For discussion about X5json structure.

For example, we can have only one code in AUTHOR and without 

pointer, but X5 propose standard schema - list of codes:

KW: [x4pointer, x4codes:[{}] ]

One could propose to drop one level of nesting by moving 

AUTHOR[0] to AUTHOR and rename “x4codes” to “authors”.

History of operations:

This can be done by:

1) Click on AUTHOR[0]; click on [Copy]

2) Click on AUTHOR; click [Clear], paste by <Ctrl/v>; [Save]

3) Click on x4pointer and click [Remove]

4) Click on x4codes, edit text Key: authors, [Save]

Note. We still need to keep “authors” under AUTHOR because we 

may have FreeText list.

Steps 3) ad 4) can be avoided by editing authors on step 1) or 2)



Specialized extensions of editor-part

Add Entry

New empty Entry 

with artificial 

ENTRY number

(continue editing JSON file as usual)
. . . . .

If Editor recognizes X5json it will 

offer new function [Add Entry] to 

the list “x4entries”.

(This is preliminary draft for 

testing concept of “specialized 

extensions” of editor)



1. JSON-Tree editor is a tool to view and edit any JSON files.

It is a full-featured editor, a universal multi-platform application 

running in a Web browser

2. Specialized extensions of viewer-part for nuclear data can help to 

understand/discuss/debug new JSON nuclear data formats

3. Specialized extensions of editor-part for nuclear data could be 

further explored and developed

4. The future of JSON-Tree editor is not yet determined

Concluding remarks



Thank you.

Citing of the materials of this presentation should be done with proper acknowledgement of the author


